• @vext01
    link
    123 months ago

    Balls.suck() is the correct syntax.

      • xigoi
        link
        English
        10
        edit-2
        3 months ago
        BallsFactory ballsFactory = new BallsFactory();
        ballsFactory.setSuckable(true);
        Balls balls = ballsFactory.create();
        
        • @whats_all_this_then@lemmy.world
          link
          fedilink
          11
          edit-2
          3 months ago

          All of this is okay, but it’s not production ready. This is what real production code looks like:

          SuckableFactory suckableFactory = new SuckableFactory();
          Suckable balls = suckableFactory
              .setShape(SuckableShapes.round)
              .setCount(2)
              .create();
          
          SuctionProvider mouth = SuctionProvider.getInstance();
          
          SuckerFactory suckerFactory = new SuckerFactory();
          Sucker sucker = SuckerFactory.create():
          
          sucker.setSuctionProvider(mouth);
          sucker.setSuckable(balls);
          sucker.setIntensity(SuckerSuctionIntensities.medium);
          sucker.suckSuckable();
          
      • @vext01
        link
        33 months ago

        Or I didn’t using the correct naming convention!